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Thank you for using Global Mapper, the all-in-one GIS application from Blue Marble Geographics. As you
will soon discover, this unique software oﬀers an extensive collection of spatial data processing tools in
an easy-to-use application that no GIS professional or map enthusiast should be without.
As you begin to explore the wealth of features and functions in Global Mapper, you will quickly learn
that this is a truly remarkable software tool. Nowhere else will you ﬁnd a single application that oﬀers
the level of ﬁle format support, data visualization options, digitizing capabilities, spatial analysis tools,
LiDAR and 3D analysis functionality, and map design tools, right out of the box.
At Blue Marble Geographics, we are committed to ensuring our customers are provided with the
information and resources necessary to eﬀectively use the software they have purchased. To that end,
we are pleased to oﬀer a collection of instructional materials to help you get up and running in no time.
This Getting Started Guide is designed to assist with the basic operation of Global Mapper and to help
you understand some of the commonly used features and functions. For a complete guide to all the
software’s capabilities, click the Help menu and choose Help… or click the F1 key on your keyboard. If
formal instruction or self-training is required, visit bluemarblegeo.com/training to ﬁnd out about
currently available programs and resources.
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The current version of Global Mapper can be downloaded from the following web page:
www.bluemarblegeo.com/products/global-mapper-download.php
Depending on your computer’s operating system, you can choose either the 32-bit or 64-bit version.
The latter will allow you to take full advantage of the extra memory available for 64-bit applications
and will improve the performance of the software. Several non-English language versions are also
available. To install Global Mapper, simply double-click the executable ﬁle Installation will take no
more than a couple of minutes.

The ﬁrst time you launch Global Mapper, you will see the Register Global Mapper window. The
option you select will determine the authorization method and the level of functionality available to
you when you run the software.
-

-

-

-

Activate single-user or trial license (log in required)
Log in with a Blue Marble Geographics account to
request a trial license or activate a single-user license
from a recent purchase (requires an order number). Use
the Manage Login link to create a new account or to
recover a lost password.
Oﬄine Activation
Activate using a license ﬁle provided to you by email.
This also displays the computer’s information that can
be sent to authorize@bluemarblegeo.com to request a
license for an oﬄine machine.
Connect to a Network License Server
If your company or organization has set up a network
licensing system, you can use this option to check out a
license while you are using the software. When you no longer need the license, it can be
returned and used by someone else in your organization.
Continue without Registering
An unregistered version of Global Mapper oﬀers limited functionality (no support saving or
loading workspaces, no export options, no 3D Viewer, etc.) and is not intended for data
management or production.

After registering Global Mapper, you will have the option to expand the software’s functionality
with add-on modules or extensions. Modules require the purchase of the appropriate license and
include the LiDAR Module (for more information, see page 19). Extensions are typically developed
and registered by third party developers, however a preconﬁgured extension called the COAST
extension is installed with Global Mapper. This powerful tool is used to analyze the ﬁnancial impact
of coastal ﬂooding.
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Global Mapper’s user interface has been designed to provide easy and intuitive access to all of the
software’s features and functions. The key elements of the interface are the menus, the toolbar,
and, of course, the map window itself. A variety of dialog boxes and ﬂoating windows provide access
to additional tools or more advanced functionality.
The Title Bar displays information
about the version of Global
Mapper and the name of the
current Workspace. For more
information, see page 8.

The Toolbars oﬀer a
Menus provide access to
convenient
way to select a The Favorites List provides easy
most of Global Mapper’s
tool,
apply
a
speciﬁc
function, access to a customizable list of
core functionality.
For more information, or change a setting. For more frequently-used tools. For more
information, see page 5.
see page 4.
information, see page 5.

The Control Center lists all
loaded layers and allows
settings to be applied to
these layers.
The Scale Bar and other onscreen
features are managed using the
Display Options.

The dockable Overview Map
displays the full extent of the
loaded data and represents the
current extent with a box.

The Attribute Editor
provides a searchable
and sortable tabular
view of the attribute
data for a selected layer

The Digitizer Right-Click Menu
oﬀers an extensive collection of
tools for creating or editing
features on the map.
For more information,
see page 12.
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Information about a
selected feature as well
as the coordinates of
the cursor are displayed
on the Status Bar.
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The menus in Global Mapper are intuitively organized by function and oﬀer access to all of the
features and functions in the application. Note that, as with other software titles, there are often
many ways to access a particular tool in Global Mapper. For example, the action of importing a layer
can be performed using the Open Data File option in the File menu; the Open Data File button in the
toolbar; or by using the Ctrl+O keyboard shortcut. How you chose to perform this and other
commonly used functions comes down to your personal preference.
The following summarizes the primary function of each menu:
-

-

-

-

-

-

-
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File
The File menu contains all of the options for importing, exporting and saving data. It also
includes a list of recently imported ﬁles, providing convenient access to frequently used layers.
Edit
The primary function of the Edit menu is to enable the copying and pasting of features and to
control the associated options.
View
The View menu includes an array of settings for conﬁguring the appearance of the interface and
of the map itself. There are also options for manually adjusting the zoom level and for saving
and restoring a speciﬁc map view.
Tools
As its name implies, the Tools menu contains a selection of tools that
are used to interact with features on the map. Based on the tool that
is selected, the function of the cursor on the map will change. This
menu also provides access to certain other dialog boxes such as the
Overlay Control Center and the Map Layout options.
Analysis
The Analysis menu consolidates many of the analytical functions into
a convenient single list. While most of the analysis tools, such as
watershed and contour generation, focus on working with elevation
data, this menu also oﬀers access to additional functions including
the Raster Calculator and Graph and Chart Manager.
Layer
The Layer menu provides access to a variety of operations that are
performed against a layer or layers selected in the Overlay Control
Center. These include attribute joining and calculation.
Search
The Search menu oﬀers several options for querying or editing
feature attributes. It also includes an address search function that
includes geocoding capability.
GPS
When a compatible GPS receiver is connected to your computer, the position can be
represented by a symbol on the map. The GPS menu controls the conﬁguration and interaction
between Global Mapper and a connected GPS device.
Help
The Help menu provides a single point of access for the various help options and other
resources that are available for Global Mapper. For more information, see page 22.
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The buttons on Global Mapper’s toolbars oﬀer the most convenient way to select a tool, to open certain
dialog boxes, or to switch between one function and another. If necessary, toolbars can be removed
from the interface using the Toolbars option in the View menu, or can be undocked or moved to
another position. Within each individual toolbar, buttons can be removed or added as needed.
The following are the buttons in the File toolbar:
The Conﬁguration button opens the
The Download Online Data button
Conﬁguration window that is used to
oﬀers access to a wealth of online data
establish numerous settings in the software.
sources such as WMS and WFS.
For more information, see page 6.
For more information, see page 11.

The Overview Map button
enables the dockable
overview window showing
the boundary area of the
main map view

The Open Data Files button is used
to initiate the import of data in any
supported format. For more
information, see page 9.
The Save button saves the status
of all imported data, digitized
features and conﬁguration
settings to a Workspace ﬁle.

The Control Center button
activates the dialog box for
managing loaded data layers.
For more information, see
page 7.

The Map Layout button is used to
create a cartographic page layout of
the current map with elements such as
a scale bar and legend.

The Toolbar Options dropdown list
allows buttons to added or removed
from the selected toolbar.

The Map View Manager
provides the ability to create
multiple 2D map displays and
to set which layers are
displayed in each. This, along
with additional windows such
as Path Proﬁle and Attribute
Editor, can be manually docked
by dragging and dropping.
The Favorites toolbar provides a convenient way to access commonly used components of Global Mapper:
The customizable Favorites
List provides easy access to
frequently used tools

The Run Selected
Command button initiates
the function selected in
the Favorites List.

Custom keyboard
shortcuts can be assigned
to selected functions.
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The Conﬁguration dialog box can be opened from the Tools menu or by clicking the
Configuration button in the toolbar and it oﬀers a single location for establishing personal
settings and preferences that control many of the features and functions of the software.
-

-

-

-

General
The General options include the default units of
measurement, background color and coordinate format.
Vector Display
The function of Vector Display is to control the
appearance of point, line, and area features on the map.
Speciﬁc options include ﬁltering data types and
adjusting the display order.
Display Options
The Display Options are used to conﬁgure the display of
map elements including the scale bar and legend.
Styles
These options are used to create and manage feature
types that can be assigned to polygons, lines, or points.
Applying a feature type to a vector feature will
automatically adjust the appearance of the feature and
assign a custom list of attributes if required.
Projection
The Projection section is used to alter the coordinate reference information for onscreen display
and reproject a layer from one system to another before exporting.
3D View Properties
3D View Properties, which is also accessible directly from the 3D Viewer, includes numerous
options for controlling the behavior and display of the 3D map view. These include vertical
exaggeration, background color, and 3D vector display. For more information, see page 11.
Vertical Options
Vertical Options oﬀers settings that control the display of elevation or terrain layers. These
settings include the selection of a shader pattern and customization of the hill shading.
Shader Options
Shader Options controls the visual display of several preconﬁgured elevation and slope shader
patterns and allows new patterns to be created.
Lidar
The Lidar settings are used for ﬁltering a point cloud based on classiﬁcation or return types.
Feature Templates
The function of Feature Templates is to create a set of preconﬁgured attributes that streamline
the process of digitizing or data collection, especially when using Global Mapper Mobile.
GPS Options
GPS Options oﬀers several settings for controlling the tracking process when using a connected
GPS receiver.

While the Conﬁguration dialog box oﬀers access to most of Global Mapper’s preferences and settings
options, many other components of the software contain feature-speciﬁc settings that are established
when performing that function. For example, when exporting a ﬁle in a particular format, many of the
preferences associated with the exported ﬁle are set in the Export Options dialog box.
6
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The Control Center is Global Mapper’s layer management tool. It
can be opened from the Tools menu, by clicking the Open Control
Center button in the Toolbar, or by using the keyboard shortcut
Alt+C. Unlike most other dialog boxes, the Control Center can
remain open while using other tools in the software. The Control
Center window can also be docked by dragging the dialog box to
one of the edges of the map window.
There are two ways in which a layer can be removed from the map display: the adjacent box in the
Control Center can be unchecked or the selected layer can be removed completely by using the
keyboard Delete key or highlighting the layer and choosing the Close (Unload Layers) button. Using
the uncheck option, the layer is retained and can be simply checked on again when needed. Closing
an overlay permanently removes it and any unsaved edits or created features will be lost.
Right-clicking on a selected layer or layers in the Control Center oﬀers a variety of options for
managing the layer. For instance, the Description or name of the layer can be changed, or multiple
layers can be grouped in a tree view. This right-click menu also oﬀers access to the Layer Options
dialog box, which is used to adjust certain settings pertaining to a layer.

The tabs in the Options dialog box diﬀer depending on the data type contained in the selected layer:
-

-

-

Vector Options
The primary functions of the Vector Options dialog box
include managing the display of labels; assigning features to
a feature-type category; and adjusting the display
characteristics of the features in the layer (ﬁll pattern,
symbol style, etc.).
Raster Options
The Raster Options dialog box includes tools for establishing
transparency; adjusting color balance, contrast, etc.; and
cropping an image to a deﬁned area.
Elevation Options
The available Elevation Options include tools for oﬀsetting
elevation values in the layer and for deﬁning the range of
visible elevations.

Each of the Options dialog boxes includes Map Zoom, to control
the zoom range within which the layer will be displayed, and
Layer Projection tab, which is used to reinterpret the coordinate
values associated with the selected layer. Adjusting these
projection parameters will result in the contents of the layer
being physically moved to a new location and should only be
performed when you know the original coordinate settings were incorrect. To simply reproject your
map, use the Projection section in the Conﬁguration dialog box (for more information, see page 6).
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The workspace is the core ﬁle management component of Global Mapper. It allows you to store
information about the layers that are displayed on the map as well as any settings or conﬁguration
that have been applied to these layers. At its most basic level, a workspace is a ﬁle (*.gmw) that
records a snapshot of your current map view.
To save your workspace, click the Save button in the
toolbar or click the File menu and select Save
Workspace... If a workspace was not previously saved,
you will be prompted to name and choose a location
for the ﬁle. You can also create a duplicate of an
existing workspace by using the File > Save Workspace As… option. This function is useful for
establishing a workspace template, possibly containing all layers or covering the full extent of your
area of interest. Any workspaces created from this template using the Save Workspace As…
command will inherit all of the layers and settings from the original and can then be individually
modiﬁed to reﬂect the requirements of a particular project or jobsite.

An important consideration when working with workspace ﬁles is that they do not actually contain
the map data from any ﬁles that are imported. Instead, the workspace records the path to the
original ﬁle location as well as any edits or conﬁguration that has been applied to this layer. If the
path to the ﬁle location is broken, such as when you disconnect from your network or when the ﬁle
is deleted or moved to a new location, the workspace will not load correctly and an error message
will be displayed. For this reason, workspace ﬁles should typically not be shared with other Global
Mapper users, assuming that the path to the included data is unique to the original computer.

Points, lines, and area features that are created using Global Mapper’s Digitizer tools are stored
directly in the workspace ﬁle. Modiﬁcations or additions made to any imported data are similarly
archived internally within the software and are only applied to the original external data using the
export function.

An eﬃcient way to share data among Global Mapper users is to create a Global Mapper Package ﬁle
(.gmp). Unlike the aforementioned workspace format, a package ﬁle contains all of the map data
from any previously imported layers and it retains all of the conﬁguration settings and edits that
were applied to these layers. A single Global Mapper package ﬁle can contain data in any format
(raster, vector, and/or elevation) and as such, it provides an extremely eﬃcient tool for exchanging
maps and spatial data among Global Mapper users.
Global Mapper package ﬁles also oﬀer a simple way to create backups of important datasets that
can easily be reimported in the event of a loss of the original data or hardware failure.
For more information on exporting, see page 20.

8
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One of the deﬁning characteristics of Global Mapper is the volume and variety of ﬁle formats that
can be imported into the software. In the current version, over 300 ﬁle-types are supported,
including all common spatial formats, such as ESRI shapeﬁles, KML ﬁles, MrSID imagery, and LiDAR
point clouds. If Global Mapper doesn’t support your data, contact Blue Marble and the software
development team will determine if the format is compatible. A list of the currently supported
formats Global Mapper Help system.

There are several ways to import data into Global Mapper: the File > Open Data File(s) command,
the Open Data File(s) button in the File Toolbar; or the Ctrl+O keyboard shortcut. In each case, you
will be prompted to browse to the required ﬁle to initiate the import process.
Aside from text ﬁles, as noted below, all vector, raster, and elevation formats are imported using the
same dialog box and the same procedure. Global Mapper is able to diﬀerentiate the various formats
and automatically assigns each to the appropriate overlay type. If required, you may be asked to
deﬁne the coordinate parameters, to verify the data format for ﬁles with unconventional sufﬁxes, or
to manual rectify the ﬁle if there is no inherent geographic reference information. For more
information on the rectiﬁcation process, see page 10.
When importing, it is possible to select multiple ﬁles by holding down the Ctrl or Shift key while
selecting the required ﬁles in the Open dialog box. Alternatively, you can open all compatible ﬁles in
a speciﬁed folder or directory tree using the File>Open All Files in a Directory Tree command.
Finally, and perhaps most conveniently, you can simply drag and drop a compatible ﬁle onto the
Global Mapper window to automatically initiate the import process.

Text ﬁles containing a list of coordinate
values can be imported into Global
Mapper and used to create points, lines,
or area features. To initiate the text ﬁle
import process, use the File > Open
Generic Text File(s) command.
After selecting the required ﬁle, you will
be prompted to assign certain
parameters for the imported ﬁle such as
the order and format of the coordinate
values, the number of header rows in
the ﬁle, and whether or not to import
accompanying attributes.
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Global Mapper’s Image Rectiﬁer function provides a powerful tool for creating a geographically
referenced raster layer from virtually any image ﬁle or PDF. The procedure usually involves
identifying visible features in the imported image and tagging each of these with their
corresponding coordinates.
To import an image, either use the standard File > Open (Ctrl +O) command or File > Rectify
(Georeference) Imagery. If you choose the latter, you have the option to directly export the resulting
raster ﬁle after the required control points have been assigned.
After selecting the ﬁle to be imported, the Image Rectiﬁer dialog box is displayed showing an
overview of the image; a zoomed view of the image in which the control points can be precisely
placed; and a zoomable view of the current map. To begin the process, click an identiﬁable point on
the image, click the corresponding point in the adjacent map, and click the Add Point to List button.
Repeat this process for
several additional points
spaced as far apart as
possible. Alternatively, you
can manually type the X and
Y pixel values from the image
and/or type the
corresponding coordinate
values derived from surveyed
ground control points.
After all of the control points
have been assigned, click the
OK button to create a new
raster layer. To correct any
errant registration points,
select the layer in the Control
Center, right-click and choose
RECTIFY – Modify Layer
Position/Projection.

As an alternative to importing ﬁles, advanced users can establish a direct connection to an existing
spatial database, which allows Global Mapper to both read and write data directly from the
database tables. Among the supported database types are ESRI ArcSDE, ESRI File and Personal
Geodatabases, MS SQL Spatial, Oracle Spatial, PostGIS, and Spatialite.
To establish a connection to a spatial database, open the Spatial Database Connection Manager
(Tools > Connection Manager), click the New button, and enter the required settings. To import data
from a connected database, click the File menu and choose Open Spatial Database, select the
database name, click the Open button, and select from the available tables.

10
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A great way to get started making maps with Global Mapper is stream data from one of the many
free online datasets. Numerous government agencies, organizations, and commercial companies
provide direct streaming access to their spatial data archives though Web Map Service (WMS), Web
Coverage Service (WCS) and other online protocols. Global Mapper includes preconﬁgured links to
many of these servers.
To initiate the download process, click the Online Sources quick-start button on the
introductory screen or click the Download Online Data button from the toolbar. In both
cases, the resulting dialog box will list all of the available Data Sources, categorized by
type or by geographic area. After expanding a category list, simply select the required data source
and set the extent of the data to download using the options at the bottom of the window.
On occasion, you may ﬁnd that the service that you require is not available and you will see an error
message to that eﬀect. This circumstance may be due to routine system maintenance, excessive
traﬃc, or other technical issues. Unfortunately Blue Marble has no control over the availability of
these online map sources so it is recommended that you save the data to a local ﬁle so you do not
have to continually depend on the streamed service. See below for more information.

Blue Marble has partnered with several commercial data providers to oﬀer convenient access to
high-quality imagery and elevation datasets. If you select one of the Premium Content options in the
Online Data Source dialog box, you will be prompted to enter the appropriate log-in details or data
access ID number to download the data. Information on subscribing to these services can be
obtained from the data provider’s web site.

While Global Mapper includes numerous preloaded maps services, you can also add custom online
sources if they are available for your area of interest. Many GIS departments now use the web as an
eﬃcient delivery mechanism for their datasets and Global Mapper allows you to set up a direct link
to this data. After clicking the Add New Source button in the Online Data dialog box, simply enter
the appropriate URL to establish this link.

Because the availability of the streaming data services cannot be guaranteed, it strongly
recommended that you save a local copy of any online map data. Not only will this ensure that you
will always have access to the required layers, even when oﬄine, but it will signiﬁcantly speed up
the map draw speed when working with this data.
To save streamed data, click the File menu and select Export > Export Raster/Image Format, choose
a ﬁle format when prompted, and enter the ﬁle settings as needed. A good format choice is JPEG
2000 (.jp2) as it provides a balance between ﬁle size and image quality. Before ﬁnalizing the export,
click the Export Bounds tab in the Export Options dialog box and choose one of the available options
to limit the geographic extent of the exported ﬁle, otherwise you may inadvertently generate an
extremely large ﬁle. Note that saving data will take considerably longer than simply displaying it on
the map, so be prepared to wait some time for the ﬁle to be saved.
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Arguably the most important tool in Global Mapper, the Digitizer allows you to create, delete, edit,
move, reconﬁgure, and copy points, lines, and area features on the map. The most frequently used
Digitizer components can be accessed directly from the Digitizer (Create) toolbar, but many more
tools are available by right-clicking on the map after the Digitizer has been enabled.
When used by itself, the Digitizer is a selection tool. After clicking the Digitizer button in
the toolbar, the position of the cursor is represented by a crosshair with the word EDIT
displayed below, and in this mode, points, lines, and area features can be selected in
preparation for editing, moving etc. Individual features can be selected by simply clicking the feature
on the map or multiple features can be simultaneously selected by clicking and dragging a box that
encompasses the extent of the required features or by holding the Ctrl key while selecting multiple
individual features.

The following buttons are used to manually create vector features on the map:
Point features or text are created by simply clicking at the required location on the map.
Line features are created by clicking at each desired shape point on the map. The line is
terminated using the right mouse button.
Trace-mode lines are created by clicking and holding the left mouse button while moving the
mouse over the map.
Area features or polygons are created by repeatedly left-clicking on the map. Right-click to
add the ﬁnal point, which is automatically connected to the ﬁrst point.
Rectangular areas are created by holding down the left mouse button while moving the
cursor between the opposite corners. Squares are created by holding the Shift button down
while dragging.
Circles are created by holding down the left mouse button while moving the cursor outwards
from the center point to deﬁne the radius. An ellipse is created by holding the Shift button
down while dragging.

The Digitizer (Advanced) toolbar contains several buttons for activating specialized vector creation
tools, such as the CoGo tool for creating line or area features by entering speciﬁc dimensions and
the Range Ring tool for generating concentric circular area features of a speciﬁed radius around a
point.
The Digitizer right-click menu oﬀers numerous advanced drawing tools that are organized in
submenus by type (areas, lines, and points) as well as an extensive collection of tools for
reformatting, editing, and converting vector features.

12
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The Modify Feature Info dialog box appears after a new feature is
created or when the right-click > EDIT option is chosen after a feature
has been selected with the Digitizer tool. This dialog box includes
options to establish the target layer for the feature, style settings, and
tools for adding or editing attributes.
The Feature Type dropdown list provides the means to assign the
selected feature to a preformatted classiﬁcation, which automatically
determines the visual characteristics as well as the attribute ﬁelds that
are associated with this type. Additional Feature Types can be added to
the list by clicking the Create New Type button.

Global Mapper provides tools for editing both the geometry and physical appearance of vector
objects as well as the attributes or information that is associated with each feature. Note that
modiﬁcations made to an imported layer are not automatically applied to the source ﬁle. Instead,
the layer must be exported in the appropriate format to apply any edits to a original ﬁle.
Before initiating any editing function, the feature or features
must be selected with the Digitizer tool as previously described.
The act of selecting a feature activates several additional buttons
in the toolbar that oﬀer such options as moving, rotating, scaling,
and converting features. Additional geometric editing options are
available by right-clicking on the map.
Global Mapper also provides the ability to edit the shape and size
of individual lines or area features by adding, moving, or deleting
vertices or shape points. To enable this function, make sure the
option to display vertices for selected objects (right-click >
Options) is enabled. Vertices can then be selected with the
Digitizer tool and, using the right-click > Vertex Editing function,
can be modified in several ways.
To restore the original geometric shape or position of a feature, select it with the Digitizer tool and
choose Move/Reshape Feature(s) > Restore Original Shape of Selected Features.

The easiest way to delete a feature in Global Mapper is to select it with the Digitizer tool and use the
Delete key on your keyboard. Although the feature will be removed from view, it is not permanently
erased and can be easily recovered if necessary. Using the keyboard shortcut Ctrl+Z immediately
after deleting the feature will undo the deletion. Alternatively, you can toggle the display of all
deleted features using the keyboard shortcut Ctrl+Shift+D and, using the Digitizer tool, right-click
and choose the Undelete option.
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The Modify Feature Info dialog box, previously described in the Using the Digitizer section, oﬀers the
option to manually add or edit attributes for one or more selected features. New attribute ﬁelds can
be created and the corresponding values can be manually entered. For large numbers of features,
this can be a time-consuming and laborious process, so it is typically recommended that attribute
ﬁelds are automatically applied by assigning them to an appropriate Feature Type or, if possible,
joining attributes from and external source.

Accessed by right-clicking on one or more layers in the Control Center, the Attribute Editor provides
a tabular display of all of the attribute data for each layer, separated into individual tabs. Within this
dialog box, attributes can be queried, sorted, edited, and exported.

The join process in Global Mapper allows external data to be assigned to the appropriate features in
an existing layer for the purpose of creating additional attribute ﬁelds. Before beginning this
procedure, it is essential that each feature has an existing attribute that matches a corresponding
value in the data being joined. The join can be based on a one-to-one match, where each entry in
the imported data matches one feature on the map, or it can be based on a one-to-many approach,
where an individual record in the data is assigned to several features on the map.
To initiate the join process, click the Join Attributes button in the Attribute Editor .
Supported formats for the external tabular data include .txt, .csv, and dbf.
The Calculate Attributes function, which is also accessed using a button in the Attribute
Editor, is used to create a new attribute ﬁeld by applying a calculation to an existing
attribute. Calculation options include standard numeric operations, such as add and
multiply; text-based operations, such as append or prepend text; or advanced formulaic operations.

Global Mapper provides several options for automatically creating or updating attributes. After
selecting a feature or features on the map with the Digitizer tool, the right-click menu oﬀers an
Attributes/Style Functions submenu that can be used to automatically assign attributes using a
variety of criteria. For instance, with an underlying elevation layer, you can assign elevation and
slope values to selected features or you can add an attribute with a count of the number or point
features inside a selected area.
14
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In order to utilize Global Mapper’s 3D functionality, the data with which you are working, must have
an inherent elevation or height value. Both vector features and appropriately formatted raster
layers can include this “Z” value and can be modeled in a three-dimensional perspective.

The most common application for 3D data is to generate a terrain surface, which is the basis of
many of Global Mapper’s analytical functions, such as watershed delineation and ﬂood level
modeling. A height value can also be applied to a vector feature or to individual vertices that
comprise a vector feature, which allows the feature to be extruded from a terrain surface.

As with the standard raster and vector data formats, there are numerous sources of 3D or elevation
data. Global Mapper’s Download Online Data function provides several preformatted datasets that
can be downloaded free of charge, or through a subscription to one of the listed data providers.
Global Mapper also supports dozens of preexisting elevation formats, such as DEM and Arc/Info Grid
files, which are imported using the normal File > Import process. Simple text ﬁles that include
elevation values along with coordinates can be imported using the File > Import Generic ASCII Text
File(s) command and can be gridded to create an elevation layer. Finally LiDAR (Light Detection and
Ranging) data can be imported and processed to create a high-resolution surface model. For more
information on working with LiDAR in Global Mapper, see page 19.

The process of generating a raster elevation layer from an array
of vector features that contain an elevation value involves
gridding the data. This procedure typically follows the import of
an XYZ text ﬁle or LiDAR ﬁle, but it can also be performed using
other vector ﬁles such as contours. To create an elevation grid
from a selected layer, right-click on the layer in the Control
Center and choose Analysis > GRID or click the Create
Elevation Grid button in the Analysis toolbar. In both
cases, the Elevation Grid Creation Options dialog box will
appear, which oﬀers a number of options for conﬁguring the
gridding process.

By default, an elevation layer will be displayed using the multicolored Atlas Shader, although there are several additional
options in the Shader dropdown list. A simulated hill shade or shadow eﬀect will also be applied to
accentuate variations in the terrain. This can be disabled using the Hill Shade button. Additional 3D
options can be established in the Conﬁguration dialog box. For more information, see page 6.
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15

A supplementary map window in Global Mapper provides the means to view any data with a
height or elevation value as a three-dimensional model. This window is opened using the 3D View
button in the toolbar. This window can also be docked adjacent to the corresponding 2D map.
Many of the same zooming and
panning functions that are used in
the 2D map view are also available
in the 3D window. Additional tools
allow the vertical exaggeration to
be increased, the perspective to be
changed to ground level, and water
inundation to be simulated. The 3D
window also includes a Save
function that allows the current 3D
view to be saved as an image.

A rapidly emerging source of data in the GIS ﬁeld, LiDAR (Light Detecting and Ranging) data provides
the raw material for creating highly accurate terrain surfaces or other 3D layers. In its native format,
LiDAR is a series of closely-spaced points, each of which contains precise coordinates, an elevation, a
classiﬁcation that denotes the type of feature that the point represents (ground, vegetation,
building, etc.), and several additional attributes. Recent developments in Global Mapper have
expanded support for both the standard LiDAR ﬁles (.las and .laz) as well as other point cloud
formats. An optional LiDAR Module is available that oﬀers advanced LiDAR processing tools. For
more information, see page 19.

LiDAR data is imported using the standard import procedure (Ctrl+O) however the subsequent
import options dialog box is unique to this format. In this window, the data can be ﬁltered, sampled,
and if required, can be directly gridded into an elevation layer.
After importing, the points will inherit the colors of the currently selected shader and will reﬂect the
elevation value if no RGB values have been assigned to each point. Using the layer’s Options dialog
box, the display of the points can be changed to represent other variables such as classiﬁcation or
intensity. Also unique to this format is the Edit function, which is accessed by right-clicking after
selecting one or more of the LiDAR points with the Digitizer. In this dialog box, the point’s
classiﬁcation can be edited and other attributes modiﬁed.
16
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Global Mapper oﬀers several analysis tools that utilize loaded elevation or terrain layers.
-

-

-

-

-

-

Watershed Modeling
This tool is used to delineate the potential for the terrain to support the ﬂow of water using
linear features to represent stream channels and area features to outline watersheds or
catchment areas.
Path Proﬁle/Line-of-Site
A Path Proﬁle is a cross-sectional view of the terrain as represented by a line feature. The Lineof-Site analysis, which will only work with a single segment line, shows where obstructions
impede the view or transmission path from one end of the line to the other.

View Shed Analysis
The View Shed tool outlines which areas are visible or are within the broadcast range of deﬁned
location. Options such as azimuth range, distance, and height of the point of origin can be
customized in the view shed analysis setup dialog box.
Water Level Rise/Flood Simulation
Based on a selected area or on actual sea level, the Water Level Rise/Flooding tool outlines
those areas that will be impacted by a specified increase in water level.
Contour Generation
The creation of contour lines is one of the most
common uses for elevation data in Global
Mapper. The Contour Generation Options dialog
box allows the contour interval to be established,
supplementary areas features to be created, and
other settings to be applied.
Calculating Volume Between Surfaces
With two overlapping elevation layers loaded,
such as a surface layer and a subsurface bedding
plane, this straightforward tool calculates the
volume of material between the two.
Comparing/Combing Terrain Surfaces
This tool creates a new elevation layer from an operation or calculation applied to the elevation
values in two overlapping layers. Operators include subtraction, average and maximum.
Cut and Fill Calculation
Available as a right-click option when either a line or area feature has been selected with the
Digitizer, the Cut and Fill calculation tool determines the volume of material that will need to be
removed and/or added to create an artiﬁcially ﬂattened surface.

For more speciﬁc instructions on the use of these analysis tools, refer to the help documentation.
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Any point, line, or area feature can have an associated z-value, which allows it to be modeled in a 3D
environment relative to other vector features or to a loaded terrain surface.
When importing a vector layer, Global Mapper will automatically look for an existing vertical
attribute, such height or elevation, and use that as the z-value. To manually assign a z-value, simply
add a new attribute to the required feature or features and type the elevation, height, or depth. To
make sure Global Mapper recognizes this attribute as a z-value, open the Options dialog box for the
layer in the Control Center and choose the appropriate attribute ﬁeld from the Get ‘Elevations’ from
Attribute Value dropdown list in the Elevations tab.
It is also possible to add a unique z-value to each vertex that comprises a line or area feature. This
procedure is initiated by clicking the Vertices button in the Modify Feature Info dialog box for a
selected feature.

Global Mapper supports several 3D Model
formats including OBJ, DAE, and STL ﬁles. These
are rendered as top-down vector features in the
2D map view but assume their full 3D
characteristics when displayed in the 3D View.
Using the LiDAR Module, 3D models can be
created from selected points in a point cloud layer
or as a by-product of the Pixels-to-Points tool. For
more information, see page 19.

Global Mapper provides a simple tool for creating a
video ﬁle that records a user-deﬁned path through
any 3D environment. The process of creating the path
is initiated with the Digitizer tool and can use a drawn
line, imported line feature, or GPS track ﬁle. The line
itself does not have to contain any particular
characteristics or attributes but is simply used to
deﬁne the course of the ﬂight.
After selecting the line, the Create Fly-Through button
will be available in the Analysis toolbar. Clicking this
button opens the Fly-Through Path Properties dialog
box, in which the ﬂight settings are established. These
settings include height above ground, ﬂight duration,
camera angle, and pitch.
In the 3D Viewer, a series of buttons control the
preview, playback, and recording of the video ﬁle.

18
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The Global Mapper LiDAR Module is an optional add-on component of the software that
signiﬁcantly enhances the LiDAR processing functionality. The key feature of the module is a toolbar
that includes buttons for reclassifying LiDAR points, applying ﬁlters, extracting vector features from
a point cloud, and for creating a point cloud from overlapping aerial images. Behind the scenes, the
Module signiﬁcantly improves the performance of LiDAR-related processes and oﬀers several
visualization options including cross-sectional viewing and editing of a swath of points.

The LiDAR Module is installed with the standard version of Global Mapper however a valid
registration key is required to activate it. This key can be ordered on the Blue Marble website or it
can be added to your original purchase. To activate the module, click the Help menu and choose
Module/Extension License Manager. Simply checking the box next to the LiDAR module will trigger
the registration window. After activating the license, the LiDAR toolbar will automatically appear.

The LiDAR Display
dropdown list oﬀers
numerous options
for adjusting the
point colors to
reﬂect a feature or
attribute of the data.

The Auto Classify Ground
Points tool identiﬁes and
classiﬁes points that are likely
to represent ground for the
purpose of creating a DTM

The Noise Removal tool
detects and reclassiﬁes
noise points in a point cloud
The Spatially Thin LiDAR tool
reduces the density of the
point cloud based on a
speciﬁed distance spacing

The Auto Classify Powerline
and Power Poles tool identiﬁes
and classiﬁes points that are
likely to represent aboveground cables and utility poles

The Auto Classify Buildings and
Vegetation tool identiﬁes and
classiﬁes points that are likely to
represent buildings and trees

The Find Duplicate LiDAR
tool ﬁnds point cloud
points with the same XYZ
location and deletes them

The LiDAR QC tool
compares or corrects
the elevation of point
cloud data to known
control points The Select LiDAR by Distance
tool identiﬁes points of a
speciﬁc class within a deﬁned
proximity of other points

The Extract Vector
Features tool creates 3D
building polygons, trees,
and powerlines from an
appropriately classiﬁed
point cloud layer
The Create 3D Model
from Selected LiDAR
tool generates a
mesh or model from
points selected with
the Digitizer

The Filter LiDAR Data tool oﬀers options
for limiting the display of points based on
classiﬁcation or return-type parameters
The Pixels-to-Points
tool creates a highdensity point cloud
from overlapping
images (see page 20)

The Apply Color button
assigns RGB values from an
underlying image layer to
each point in a point cloud
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This powerful component of the LiDAR Module uses the principles of photogrammetry to create a
high-density point cloud from overlapping geotagged images. Ideally suited for UAV or drone
operators, Pixels-to-Points analyzes the relationship between recognizable objects in adjacent
images to determine the three-dimensional coordinates of the corresponding surface. As a byproduct of the point cloud generation capability, the Pixels-to-Points tool also oﬀers the option of
creating an orthorectiﬁed image and/or a 3D mesh.
To create a point cloud, simply click the Pixels-to-Points button and load your images
into the resulting dialog box. Apply the necessary settings and add ground control
points if available before clicking the Run button.
The

Pixels-to-Points process is memory intensive and may take several hours to process depending on the
input data and quality settings.
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Eﬃcient file exporting and map sharing are essential components of any GIS and play a major role in
the functional makeup of Global Mapper. Just as the software can support a vast array of ﬁle
formats for importing, similarly hundreds of ﬁle-types can be exported ensuring Global Mapper’s
interoperability with many third-party applications.
When exporting data from Global Mapper, there are several issues and factors that need to be
taken into account:
- All compatible layers and/or visible features will be exported by default. In other words, Global
Mapper will create a single ﬁle for all displayed layers by merging multiple layers into one ﬁle. In
order to export the contents of a speciﬁc layer, right click on the required layer in the Overlay
Control Center and choose Layer > EXPORT.
- There is no automated process for saving edits or additions to an imported ﬁle. In order to save
changes to the source ﬁle, you need to export the layer in the same format and overwrite the
original ﬁle.
- The projection and coordinate settings for any exported data are established in the Projection
tab of the Conﬁguration dialog box (for more information, see page 6). Regardless of the
projection parameters of each imported layer, this global projection will be assigned to all
exports.
- Each export format’s options dialog box has a set of format-speciﬁc settings that are applied to
the ﬁle being exported. Common to all formats are an Export Bounds option, that can be used to
limit the geographic extent of the data being exported, and a Gridding or Tiling option that can
be used to break up a single large ﬁle into several smaller ﬁles.

When sharing data with other users of Global Mapper, the
Global Mapper Package format is the preferred choice. This
proprietary format supports all compatible data-types and
allows multiple layers to be simultaneously transferred in a
single compressed ﬁle. When imported, the Global Mapper
package ﬁle will recreate the layer structure of the original data.
Global Mapper package ﬁles can also be employed as a means
for backing up critical datasets. This ensures that the data can
be eﬀectively restored in the event of a loss of the original data
or hardware failure. To create a package ﬁle, click the File menu
and select Export > Export Global Mapper Package File…

Unlike Global Mapper’s import process in which a single Open
command is used to access all compatible data, exporting
requires the selection of a data type (vector, raster, or
elevation) and subsequently a speciﬁc ﬁle format. The Export
submenu under the File menu oﬀers these three options. The
selection of a format for the exported data will depend on the intended use of the resulting ﬁle and
its compatibility with the third party software into which it will be imported.
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In the same way that Global Mapper provides a streamlined way to import data from a spatial
database, any loaded data, regardless of its origin, can be written out to any of the supported
database formats. As when exporting data in ﬁle format, the Export submenu provides three
database export options: raster, vector, and elevation. For more information on establishing a
connection to a spatial database, see page 10.

MangoMap is an online mapping service that provides a simple and eﬃcient way to share geospatial
data with anyone, on any device. Beginning in version 21, Global Mapper users can set up a
MangoMap subscription and publish map directly from the software. To initiate the process, click
the MangoMap button the toolbar.

Before sending a map to a connected printer, Global
Mapper oﬀers a powerful page layout tool that can be
used to add cartographic elements such as a title,
legend, and scale bar to the map. Using a what-yousee-is-what-you-get approach, the Map Layout Editor
simpliﬁes the production individual maps or map
books.

Capturing a map view as a Portable Document Format
(PDF) allows the map to be shared with virtually
anyone, regardless of their computer’s operating
system. Global Mapper’s PDF export function also
retains the inherent layering structure and geographic
referencing information so that the map viewer can
turn on and oﬀ layers as needed, can see the
coordinates when their cursor is moved over the map,
and can perform simple cartographic functions such
as measuring distances.
Exporting a PDF is similar to sending a map to a printer and includes many of the same setup
options. To create a PDF, click File > Export > Export PDF File… Additionally, a geospatial PDF can be
created in the Map Layout Editor window.

Perhaps the simplest way to share a map, the Capture Screen Contents to Image command is an
available option in the File menu or by using the Shift+C keyboard shortcut. The resulting dialog box
oﬀers the choice of four common image formats and includes an option to save a projection and/or
world ﬁle that will allow the image to be imported into a third party GIS application.
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Global Mapper’s searchable help system is automatically
installed with the software and is accessed from the Help
menu or by clicking the F1 key. You can either browse
through the contents section or search for a keyword to ﬁnd
information on the function in question. Embedded
hyperlinks help you navigate between sections and provide
supplementary information about the selected topic.

-

An online version of the complete User’s Manual is
available here:
www.bluemarblegeo.com/knowledgebase/global-mapper
Recordings of the Global Mapper webinar series, which cover a variety of topics in the software
can be viewed here:
www.bluemarblegeo.com/products/webinars.php

The Global Mapper Forum is an active online community of users and experts from a wide variety of
industries and ﬁelds. Forum participants have the opportunity to ask questions, oﬀer tips, and
participate in discussions about the use of the software and its future development. Many new
users ﬁnd browsing through the posted topics to be an invaluable part of their learning experience.
A link to the Global Mapper Forum is available in the software’s Help menu or you can navigate
directly to the following site:
www.globalmapperforum.com

Both public and company-speciﬁc training opportunities are available to help you get the most out
of the software. The availability of scheduled public classes and information about registering is
posted here:
www.bluemarblegeo.com/training
Customized onsite or online classes can also be arranged for individual companies or organizations.
For information, email:
training@bluemarblegeo.com

After all other self-help options have been tried, on-demand support is available to resolve any
issues with the installation, registration, or performance of the software. Support requests are
initiated using the preconﬁgured form on the following web page:
www.bluemarblegeo.com/support/support.php
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Open the User Guide ............................................................................................................................ F1
Display 3D Window ........................................................................................................................ Ctrl+3
Print ................................................................................................................................................ Ctrl+P
Alt+X .......................................................................................................................... Exit Global Mapper

Open data ﬁle (import) .................................................................................................................. Ctrl+O
Save the current workspace ...........................................................................................................Ctrl+S
Load a workspace .......................................................................................................................... Ctrl+W
Unload (remove) all layers ............................................................................................................. Ctrl+U
Copy selected features to the clipboard ........................................................................................ Ctrl+C
Delete and copy selected features to the clipboard ...................................................................... Ctrl+X
Paste features from the clipboard to a selected layer ................................................................... Ctrl+V
Open the Overlay Control Center .....................................................................................................Alt+C

Digitizer Tool.................................................................................................................................... Alt+D
Feature Info Tool ..............................................................................................................................Alt+P
Measure Tool.................................................................................................................................. Alt+M
Zoom Tool ......................................................................................................................................... Alt+Z

Zoom in ................................................................................................................................... Page Down
Zoom out ..................................................................................................................................... Page Up
Zoom to full extent of all loaded data ............................................................................................ Home
Pan the Map (¼ screen increments)....................................................................................... Arrow Keys
Pan the Map (Entire screen) .......................................................................................... Ctrl+ Arrow Keys

Edit the feature under the cursor.................................................................................. Left Double-Click
Select a feature and automatically enter move mode ........................................................ Alt+Left Click
Undo last operation.........................................................................................................................Ctrl+Z
Cancel the current operation .............................................................................................................. Esc
Delete the selected feature ............................................................................................................Delete
Undelete the selected feature ............................................................................................. Shift+Delete
Temporarily disable snapping when drawing a feature ...................................................... Alt+Left Click

Additional keyboard shortcuts can be manually assigned using the Favorites dropdown list in the
toolbar. For more information, see page 5.
24

Copyright Blue Marble Geographics 2019

After installing Global Mapper, launch the software and you will see the Register Global Mapper
widow. If you purchased a license, enter your account information as prompted to unlock the full
functionality. For more information, see page 2.

Open the Conﬁguration dialog box (Tools > Conﬁgure), select the Projection section and update the
projection and coordinate parameters as needed. These settings will be applied to all loaded data
and will be applied to exported layers.

Click the View menu and choose Background Color... The selected color will be saved in the current
workspace.

Use the Ctrl+Shift+D keyboard shortcut to toggle the display of deleted features. Select the required
feature with the Digitizer tool, right-click on the map, and choose Undelete to restore the feature to
its original state. Alternatively, use the Ctrl+Z keyboard shortcut right after deleting the feature.

Select the New Point tool from the Digitizer (Create) toolbar and click at the location of the map
where you would like to place the text. In the resulting Modify Feature Info dialog box, type the text
you would like to add in the Name ﬁeld and choose Text from the Feature Type dropdown list.

After the required online data is displayed on in the map window, click the File menu and choose
Export > Export Raster/Image Format. In the Export Options dialog box, make sure the Export
Bounds settings match the geographic coverage requirements. Leaving the default All Loaded Data
may result in an extremely large ﬁle and increase processing time. After the export process is
complete, close the connection to the online data in the Overlay Control Center and import the
previously exported ﬁle.

There are several tools that can be employed to streamline certain data processing tasks. In the File
menu, the Batch Convert/Reproject command can be used to collectively translate multiple ﬁles of a
speciﬁc type into another format and/or to reproject the data to another coordinate system.
Scripting can also be used to automate multiple tasks in a workﬂow. A script is a simple text ﬁle that
contains a series of commands and associated parameters for importing, processing and exporting
data. For more information on scripting go to the following web page:
www.bluemarblegeo.com/knowledgebase/global-mapper/ScriptReference.html
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