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Thank you for downloading Global Mapper®, the all-in-one GIS application that everyone can use. 
This remarkable software combines a powerful array of spatial data processing tools with an 
unmatched list of compatible file formats resulting in a program that no GIS professional or map 
enthusiast should be without. 
 
As you begin to explore the wealth of features and functions in Global Mapper, you will quickly learn 
that this is a truly unique software tool. Nowhere else will you find a single application that offers 
the level of data support, digitizing capabilities, spatial analysis, and map creating tools, at a cost 
that will ensure a rapid return on your investment. 
 
At Blue Marble Geographics, we are committed to ensuring our customers are provided with the 
information and tools necessary to effectively use the software they have purchased. To that end, 
we are pleased to offer a number of resources to help you get up and running in no time.  
 
This Getting Started Guide is designed to assist with the basic operation of Global Mapper and to 
help you understand some of the commonly used features and functions. For a complete guide to all 
ǘƘŜ ǎƻŦǘǿŀǊŜΩǎ ŎŀǇŀōƛƭƛǘƛŜǎ, click the Help menu and choose HelpΧ or click the F1 key on your 
keyboard. 
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The current version of Global Mapper is freely downloadable from the following web page: 
www.bluemarblegeo.com/global-mapper/product/download_complete.php 
 
5ŜǇŜƴŘƛƴƎ ƻƴ ȅƻǳǊ ŎƻƳǇǳǘŜǊΩǎ ƻǇŜǊŀǘƛƴƎ ǎȅǎǘŜƳΣ ȅƻǳ Ŏŀƴ ŎƘƻƻǎŜ ŜƛǘƘŜǊ ǘƘŜ он-bit or 64-bit version. 
The latter will allow you to take full advantage of the extra memory available for 64-bit applications 
and will improve the performance of the software. Several non-English language versions are also 
available. To install Global Mapper, simply double-click or run the downloaded executable file 
(global_mapper_setup.exe or global_mapper_setup_64bit.exe). Installation will take no more than a 
couple of minutes. 
 

The first time you launch Global Mapper, you will see the Register Global Mapper window. The 

option you select will determine the level of functionality available to you when you run the 

software. 

- Order ID from Recent Purchase 

Enter your order number and Global Mapper will be automatically 

registered, unlocking the full functionality of the software.  This 

procedure requires an internet connection. 

- Connect to a Network License Server 

If your company has chosen to deploy Global Mapper using the 

convenient network licensing option, you can connect to the 

appropriate server to register your version of Global Mapper 

- Select a License File (.lic) File Provided via Email 

If you work in an offline environment, you may request a License File 

to manually register Global Mapper. If this is the case, you will be 

prompted to browse to the location where you saved this file, after 

which, you will have full access to the software. To request a .lic file, 

please contact Blue Marble at authorize@bluemarblegeo.com 

- Request a Two-Week Trial License 

To evaluate Global Mapper, you can request a 14-day trial license that 

will allow you to test all of its features and functions. During this time, you will be limited to two 

exports for each file type (vector, raster, and elevation). 

In recent releases of Global Mapper, additional functionality has be added to the software through 

preconfigured modules or third party extensions. To activate these add-on components, click the 

Help menu and choose Module/Extension License Manager. Modules require the purchase of the 

appropriate license and include the LiDAR module (for more information, see page 19). Extensions 

are typically developed and registered by third party developers. Two preconfigured extensions are 

installed with Global Mapper: the Overview Map extension and the COAST extension for analyzing 

the financial impact of coastal flooding.  

http://www.bluemarblegeo.com/global-mapper/product/download_complete.php
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Dƭƻōŀƭ aŀǇǇŜǊΩǎ ǳǎŜǊ ƛƴǘŜǊŦŀŎŜ Ƙŀǎ ōŜŜƴ ŘŜǎƛƎƴŜŘ ǘƻ ǇǊƻǾƛŘŜ Ŝŀǎȅ ŀƴŘ ƛƴǘǳƛǘƛǾŜ ŀŎŎŜǎǎ ǘƻ ŀƭƭ ƻŦ ǘƘŜ 
softwaǊŜΩǎ ŦŜŀǘǳǊŜǎ ŀƴŘ ŦǳƴŎǘƛƻƴǎ. The key elements of the interface are the menus, the toolbar, 
and, of course, the map window itself. A variety of dialog boxes and floating windows provide access 
to additional tools or more advanced functionality. 
  

The Favorites List provides easy 
access to a customizable list of 
frequently-used tools. For more 

information, see page 5. 

The Scale Bar and other 
display features are 
managed using the 

Map Layout function. 

Information about a 
selected feature as well as 

the coordinates of the 
cursor are displayed on the 

Status Bar. 

The Overlay Control 
Center lists all loaded 

layers and allows certain 
settings to be applied to 

these layers. 

The Digitizer Right-Click Menu 
offers an extensive collection of 

tools for creating or editing 
features on the map.  
For more information,  

see page 12. 

The Title Bar displays information 
about the version of Global 

Mapper and the name of the 
current Workspace. For more 

information, see page 8. 

The Toolbars offer a 
convenient way to select a 

tool, apply a specific function, 
or change a setting. For more 

information, see page 5. 

Menus provide access to 
Ƴƻǎǘ ƻŦ Dƭƻōŀƭ aŀǇǇŜǊΩǎ  

core functionality. 
For more information,  

see page 4. 
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The menus in Global Mapper are intuitively organized by function and offer access to all of the 
features and functions in the application. Note that, as with other software titles, there are often 
many ways to access a particular function in Global Mapper. For example the action of importing a 
layer can be performed using the Open Data File option in the File menu; the Open Data File button 
in the toolbar; or by using the Ctrl+O keyboard shortcut. How you chose to perform this and other 
commonly used functions comes down to your personal preference. 
 
The following summarizes the primary function of each menu: 

 
- File 

The File menu contains all of the options for importing, exporting and saving data. It also 
includes a list of recently imported files, providing convenient access to frequently used layers.  

- Edit 
The primary function of the Edit menu is to enable the copying and pasting of features and to 
control the associated options. 

- View 
The View menu includes an array of settings for configuring the appearance of the interface and 
of the map itself. There are also options for manually adjusting the zoom level and for saving 
and restoring a specific map view. 

- Tools 
As its name implies, the Tools menu contains a selection of tools that 
are used to interact with features on the map. Based on what is 
selected, the function of the cursor on the map will change. This 
menu also provides access to certain other dialog boxes such as the 
Overlay Control Center and the Map Layout options. 

- Analysis 
The Analysis menu consolidates many of the analytical functions into 
a convenient single list. While many of the analysis tools, such as 
generating contours and delineating watersheds, focus on working 
with elevation data, this menu also offers access to tools including 
the Raster Calculator and Graph and Chart Manager. 

- Layer 
The Layer menu provides access to a variety of operations that are 
performed against a layer or layers selected in the Overlay Control 
Center. These include attribute joining and calculation. 

- Search 
The Search menu offers several options for querying or editing 
feature attributes. It also includes an address search function that includes geocoding capability. 

- GPS 
When a compatible GPS receiver is connected to your computer, the position can be 
represented by a symbol on the map. The GPS menu controls the configuration and interaction 
between Global Mapper and a connected GPS device.  

- Help 
The Help menu provides a single point of access for the various help options and other 
resources that are available for Global Mapper. For more information, see page 22.  
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¢ƘŜ ōǳǘǘƻƴǎ ƻƴ Dƭƻōŀƭ aŀǇǇŜǊΩǎ toolbars offer the most convenient way to select a tool, to open certain 
dialog boxes, or to switch between one function and another. If necessary, toolbars can be removed 
from the interface using the Toolbars option in the View menu, or can be undocked or moved to 
another position. Within each individual toolbar, buttons can be removed or added as needed. 
 
The following are the buttons in the File toolbar: 
 
 
  

The Open Data Files button is used 
to initiate the import of data in any 

supported format. For more 
information, see page 9. 

 

The Download Online Data button 
offers access to a wealth of online data 

sources such as WMS and WFS.  
For more information, see page 11. 

 

The Overlay Control Center 
button activates the dialog 
box for managing loaded data 
layers.  
For more information, see 
page 7. 
 

The Save button saves the status 
of all imported data, digitized 

features and configuration 
settings to a Workspace file. 

The Map Layout button is used to 
add cartographic features such as a 
scale bar and legend to the map in 

preparation for printing. 
 

The Configuration button opens the 
Configuration window that is used to 
establish numerous settings in the software. 
For more information, see page 6. 
 

The Favorites toolbar provides a convenient way to access commonly used components of Global Mapper: 
 

The Map View Manager 

provides the ability to divide 

the main map window into 

multiple map displays. These 

can include multiple 2D views, 

path profiles or a 3D display.  

The Run Selected 
Command button initiates 
the function selected in 
the Favorites List. 

The customizable Favorites 
List provides easy access to 

frequently used tools 

The Toolbar Options dropdown list 
allows buttons to added or removed 
from the selected toolbar. 
 

Custom keyboard 
shortcuts can be assigned 

to selected functions. 

The Overview Map button 

enables the dockable 

overview window showing 

the boundary area of your 

main map view 
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The Configuration dialog box can be opened from the Tools menu or by clicking the Configuration 
button in the toolbar and it offers single location for establishing personal settings and preferences 
that control many of the features and functions of the software. 
 
- General 

The General options include the establishment 
of default units of measurement, map grid 
display, and coordinate format. 

- Vector Display 
The function of Vector Display is to control the 
appearance of point, line, and area features on 
the map. Specific options include filtering data 
types and adjusting the layer display order. 

- Point/Area/Line Styles 
These options are used to create and manage 
feature types that can be assigned to 
polygons, lines, or points. Applying a feature 
type to a vector feature will automatically 
adjust the appearance of the feature and 
assign a custom list of attributes if required. 

- Vertical Options 
Vertical Options offers settings that control 
the display of elevation or terrain layers. These 
settings include the selection of a shader 
pattern and customization of the hill shading. 

- Shader Options 
Shader Options controls the visual display of several preconfigured elevation and slope shader 
patterns and allows new patterns to be created. 

- Lidar 
The Lidar settings are used for filtering a point cloud based on classification or return types. 

- Feature Templates 
The function of Feature Templates is to create a set of preconfigured attributes that streamline 
the process of digitizing or data collection, especially when using Global Mapper Mobile. 

- GPS Options 
GPS Options offers several settings for controlling the tracking process when using a connected 
GPS receiver. 

- Projection 
The Projection tab is used to alter the coordinate reference information for onscreen display 
and reproject a layer from one system to another before exporting. 

 
²ƘƛƭŜ ǘƘŜ /ƻƴŦƛƎǳǊŀǘƛƻƴ ŘƛŀƭƻƎ ōƻȄ ƻŦŦŜǊǎ ŀŎŎŜǎǎ ǘƻ Ƴƻǎǘ ƻŦ Dƭƻōŀƭ aŀǇǇŜǊΩǎ ǇǊŜŦŜǊŜƴŎŜǎ ŀƴŘ ǎŜǘǘƛƴƎǎ 
options, many other components of the software contain feature-specific settings that are established 
when performing that function. For example, when exporting a file in a particular format, many of the 
preferences associated with the exported file are set in the Export Options dialog box.   
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The Overlay Control Center is Dƭƻōŀƭ aŀǇǇŜǊΩǎ layer 
management tool. It can be opened from the Tools menu, by 
clicking the Open Control Center button in the Toolbar, or by 
using the keyboard shortcut Alt+C. Unlike most other dialog 
boxes, the Overlay Control Center can remain open while 
using other tools in the software. The Overlay Control Center 
can also be docked by dragging the dialog box to one of the 
edges of the map window.  
 
There are two ways in which a layer can be removed from the map display: the adjacent box in the 
Overlay Control Center can be unchecked or the selected layer can be removed completely by using 
the keyboard Delete key or highlighting the layer and choosing the        Close (Unload Layers) button. 
Using the uncheck option, the layer is retained and can be simply checked on again when needed. 
Closing an overlay permanently removes it and any unsaved edits or created features will be lost.  
 
Right-clicking on a selected layer or layers in the Overlay Control Center offers a variety of options 
for managing the layer. For instance, the Description or name of the layer can be changed or 
multiple layers can be grouped in a tree view. This right-click menu also offers access to the Layer 
Options dialog box, which is used to adjust certain settings pertaining to a layer. 
 

The tabs in the Options dialog box differ depending on the data type contained in the selected layer: 
 
- Vector Options 

The primary functions of the Vector Options dialog box include 
managing the display of labels; assigning features to a feature-type 
category; and adjusting the display characteristics of the features in 
the layer (fill pattern, symbol style, etc.). 

- Raster Options 
The Raster Options dialog box includes tools for establishing 
transparency; adjusting color balance, contrast, etc.; and cropping 
an image to a defined area. 

- Elevation Options 
The available Elevation Options include tools for offsetting elevation 
values in the layer and for defining the range of visible elevations. 

 
Each of the Options dialog boxes includes Map Zoom, to control the 
zoom range within which the layer will be displayed, and Layer 
Projection tab, which is used to reinterpret the coordinate values 
associated with the selected layer. Adjusting these projection 
parameters will result in the contents of the layer being physically 
moved to a new location and should only be performed when you know 
the original coordinate settings were incorrect. To simply reproject your 
map, use the Projection tab in the Configuration dialog box (for more 
information, see page 6).  
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The workspace is the core file management component of Global Mapper. It allows you to store 
information about the layers that are displayed on the map as well as any settings or configuration 
that have been applied to these layers. At its most basic level, a workspace is a file (*.gmw) that 
records a snapshot of your current map view. 
 
To save your workspace, click the Save button in the toolbar or 
click the File menu and select Save Workspace... If a workspace 
was not previously saved, you will be prompted to name and 
choose a location for the file. You can also create a duplicate of 
an existing workspace by using the File > {ŀǾŜ ²ƻǊƪǎǇŀŎŜ !ǎΧ 
option. This function is useful for establishing a workspace template, possibly containing all possible 
layers or covering the full extent of your area of interest. Any workspaces created from this 
ǘŜƳǇƭŀǘŜ ǳǎƛƴƎ ǘƘŜ {ŀǾŜ ²ƻǊƪǎǇŀŎŜ !ǎΧ ŎƻƳƳŀƴŘ ǿƛƭƭ ƛƴƘŜǊƛǘ ŀƭƭ ƻŦ ǘƘŜ ƭŀȅŜǊǎ ŀƴŘ ǎŜǘǘƛƴƎǎ ŦǊƻƳ ǘƘŜ 
original and can then be individually modified to reflect the requirements of a particular project or 
jobsite. 
 

An important consideration when working with workspace files is that they do not actually contain 
the map data from any files that are imported. Instead, the workspace records the path to the 
original file location as well as any edits or configuration that has been applied to this layer. If the 
path to the file location is broken, such as when you disconnect from your local network or when 
the file is deleted or moved to a new location, the workspace will not load correctly and an error 
message will be displayed. For this reason, workspace files should typically not be shared with other 
Global Mapper users, based on the assumption that the path to the included data is unique to the 
original computer. 
 

tƻƛƴǘǎΣ ƭƛƴŜǎΣ ŀƴŘ ŀǊŜŀ ŦŜŀǘǳǊŜǎ ǘƘŀǘ ŀǊŜ ŎǊŜŀǘŜŘ ǳǎƛƴƎ Dƭƻōŀƭ aŀǇǇŜǊΩǎ 5ƛƎƛǘƛȊŜǊ ǘƻƻƭǎ are stored 
directly in the workspace file. Modifications or additions made to any imported data are similarly 
archived internally within the software and are only applied to the original external data using the 
export function. 

 

An efficient way to share data among Global Mapper users is to create a Global Mapper Package file 
(.gmp). Unlike the aforementioned workspace format, a package file contains all of the map data 
from any previously imported layers and it retains all of the configuration settings and edits that 
were applied to these layers. A single Global Mapper package file can contain data in any format 
(raster, vector, and/or elevation) and as such, it provides an extremely efficient tool for exchanging 
maps and spatial data among Global Mapper users. 
 
Global Mapper package files also offer a simple way to create backups of important datasets that 
can easily be reimported in the event of a loss of the original data or hardware failure. 
 
For more information on exporting, see page 20. 
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One of the defining characteristics of Global Mapper is the volume and variety of file formats that 
can be imported into the software. In the current version, over 250 file-types are supported, 
including all common spatial formats, such as ESRI shapefiles, KML files, MrSID imagery, and LiDAR 
point clouds. Virtually any type of geospatial data is supported in Global Mapper, including raster, 
vector, 2D, and 3D, whether referenced ƻǊ ƴƻǘΦ LŦ Dƭƻōŀƭ aŀǇǇŜǊ ŘƻŜǎƴΩǘ ǎǳǇǇƻǊǘ ȅƻǳǊ ŘŀǘŀΣ contact 
Blue Marble and the software development team will determine if the format is compatible. A list of 
the currently supported formats is available in the Global Mapper section of bluemarblegeo.com 
 

There are several ways to import data into Global Mapper. You can use the File > Open Data File(s) 
command; you can click the Open Data File(s) button in the File Toolbar; or you can use the Ctrl+O 
keyboard shortcut. In each case, you will be prompted to browse to the required file to initiate the 
import process. 
 
Aside from text files, as noted below, all vector, raster, and elevation formats are imported using the 
same dialog box and the same procedure. Global Mapper is able to differentiate the different 
formats and automatically assigns each to the appropriate overlay type. If required, you may be 
asked to define the coordinate parameters, to verify the data format for files with unconventional 
suffixes, or to manual rectify the file if there is no inherent geographic reference information. For 
more information on the rectification process, see page 10. 
 
When importing, it is possible to select multiple files by holding down the Ctrl or Shift key while 
selecting the required files in the Open dialog box. Alternatively, you can open all compatible files in 
a specified folder or directory tree using the File>Open All Files in a Directory Tree command. 
 
Finally, and perhaps most conveniently, you can simply drag and drop a compatible file onto the 
Global Mapper window to automatically initiate the import process. 

 

Text files containing a list of coordinate 
values can be imported into Global Mapper 
and used to create points, lines, or area 
features. To initiate the text file import 
process, use the File > Open Generic Text 
File(s) command. 
 
After selecting the required file, you will be 
prompted to assign certain parameters for 
the imported file such as the order and 
format of the coordinate values, the 
number of header rows in the file, and 
whether or not to import accompanying 
attributes.  
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Dƭƻōŀƭ aŀǇǇŜǊΩǎ Image Rectifier function provides a powerful tool for creating a geographically 
referenced raster layer from virtually any image file or PDF. The procedure usually involves 
identifying visible features in the imported image and tagging each of these with their 
corresponding coordinates. 
 
To import an image, you can 
either use the standard File > 
Open (Ctrl +O) command or File 
> Rectify (Georeference) 
Imagery. If you choose the latter, 
you have the option to directly 
export the resulting raster file 
after the required control points 
have been assigned. 
 
After selecting the file to be 
imported, the Image Rectifier 
dialog box is displayed showing 
an overview of the image; a 
zoomed view of the image in 
which the control points can be 
precisely placed; and a zoomable 
view of the current map. To 
begin the process, click an 
identifiable point on the image, click the corresponding point in the adjacent map, and click the Add 
Point to List button. Repeat this process for several additional points spaced as far apart as possible. 
Alternatively, you can manually type the X and Y pixel values from the image and/or type the 
corresponding coordinate values derived from surveyed ground control points. 
 
After all of the control points have been assigned, click the OK button to create a new raster layer. 
To correct any errant registration points, select the layer in the Overlay Control Center, right-click 
and choose RECTIFY ς Modify Layer Position/Projection. 

 

As an alternative to importing files, advanced users can establish a direct connection to an existing 
spatial database, which allows Global Mapper to both read and write vector data directly from the 
database tables. Among the supported database types are ESRI ArcSDE, ESRI File and Personal 
Geodatabases, MS SQL Spatial, Oracle Spatial, PostGIS, and Spatialite. The ESRI databases also 
support raster data formats but are only available in the 32-bit version of Global Mapper. 
 
To establish a connection to a spatial database, open the Spatial Database Connection Manager 
(Tools > Connection Manager), click the New button, and enter the required settings. To import data 
from a connected database, click the File menu and choose Open Spatial Database, select the 
database name, click the Open button, and select from the available tables. 
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A great way to get started making maps with Global Mapper is to download some of the many free 
online datasets. Numerous government agencies, organizations, and commercial companies provide 
direct streaming access to their spatial data archives though Web Map Service (WMS), Web 
Coverage Service (WCS) and other online protocols. Global Mapper includes preconfigured links to 
many of these servers. 
 
To initiate the download process, click the Download Free Maps/Imagery from Online Sources quick-
start button on the introductory screen or click the Download Online Data button from the toolbar. 
In both cases, the resulting dialog box will list all of the available Data Sources, categorized by type 
or by geographic area.  After expanding a category list, simply select the required data source and 
set the extent of the data to download using the options at the bottom of the window. 
 
On occasion, you may find that the service that you require is not available and you will see an error 
message to that effect. This circumstance may be due to routine system maintenance, excessive 
traffic, or other technical issues. Unfortunately Blue Marble has no control over the availability of 
these online map sources so it is recommended that you save the data to a local file so you do not 
have to continually depend on the streamed service. See below for more information. 
 

Blue Marble has partnered with several commercial data providers to offer convenient access to 
high-quality imagery and elevation datasets. If you select one of the Premium Content options in the 
Online Data Source dialog box, you will be prompted to enter the appropriate log-in details or data 
access ID number to download the data. Information on subscribing to these services can be 
obtained from the data ǇǊƻǾƛŘŜǊΩǎ ǿŜō ǎƛǘŜΦ  
 

While Global Mapper includes a number of preloaded maps services, you can also add custom 
online sources if they are available for your area of interest. Many GIS departments now use the 
web as an efficient delivery mechanism for their datasets and Global Mapper allows you to set up a 
direct link to this data. After clicking the Add New Source button in the Online Data dialog box, 
simply enter the appropriate URL to establish this link. 
 

Because the availability of the streaming data services cannot be guaranteed, it strongly 
recommended that you save a local copy of any online map data. Not only will this ensure that you 
will always have access to the required layers, even when offline, but it will significantly speed up 
the map draw speed when working with this data. 
 
To save downloaded data, click the File menu and select Export > Export Raster/Image Format, 
choose a file format when prompted, and enter the file settings as needed. A good format choice is 
JPEG 2000 (.jp2) as it provides a balance between file size and image quality. Before finalizing the 
export, click the Export Bounds tab in the Export Options dialog box and choose one of the available 
options to limit the geographic extent of the exported file, otherwise you may inadvertently 
generate an extremely large file. Note that saving data will take considerably longer than simply 
displaying it on the map, so be prepared to wait some time for the file to be saved.  


