Blue Marble Geographics
Log in

Global Mapper

How Do I...

Question: How do I change the projection that I'm viewing my data in?


The current workspace projection can be modified on the Projection tab of the Configuration dialog. You can access the Configuration dialog either from the toolbar or under the Tools menu. Data imported to and exported from the workspace will assume the new projection.

Question: How do I change the projection that my data will be exported in?


All data exports use the current view projection to export data in. The current view projection can be modified on the Projection tab of the Configuration dialog. You can access the Configuration dialog either from the toolbar or under the Tools menu.

Question: How do I setup a local grid projection?


Typically, for a local grid projection where you know the latitude and longitude of at least one point in the grid coordinate system, you simply setup a new projection using either the Orthographic or Transverse Mercator projection system.

When setting up the projection set the Central Meridian and Origin Latitude to the lat/lon of the known point and set the False Easting and False Northing parameters to the grid coordinates of your known point. Finally, make sure to select the proper units for your grid system.

Question: How can I change the color that is used to fill in areas of no data when exporting to an image format?


You can change the background color used both for display and for filling in areas with no data under the View menu.

Question: Can I create new features by tracing over loaded data and then exporting a new file?


Yes, you can use the Digitizer tool to draw new features on top of loaded data. You can also edit existing features with this tool. New and edited features can be exported to new vector files in any of the supported vector formats, such as ESRI Shapefiles and DXF.

Question: How do I drape raster imagery (i.e. DRGs or aerial photos) over elevation data (i.e. DEMs)?


To drape raster imagery over gridded elevation data, first load the elevation data, then the raster data. Open the Overlay Control Center (found on the toolbar and under the Tools menu), highlight the raster image(s) you want to drape, and select the Options button. Select the Texture Map option on the Display tab and press OK. The raster image(s) should now be draped over the elevation data and shaded. Note that you will have to have hill shading enabled in order to see any difference (this is the rightmost button on the toolbar).

Question: How do I remove the collar from DRGs?


To remove the collar from USGS DRGs, open the Control Center (found on the toolbar and under the Tools menu), highlight the DRG(s) that you want to remove the collar from, and select the Options button. Go to the Cropping tab of the dialog that appears and select the Automatically Crop DRG-style Collar option and press OK. The collar should now be removed from the selected DRG(s).

If for some reason the collar was not correctly removed, you may need to specify the collar bounds manually. To do this, press the Options button again and go to the Cropping tab and manually specify a boundary to crop the collar to.

Question: How come there is a thin border around exported DRGs (or image files) even after I have removed the collar in Global Mapper?


The problem of an extra border around exported DRGs that have had the collar removed is caused by the fact that DRG Quads are NOT rectangular in the UTM projection after their collar has been removed. Rather, they are aligned on lat/lon grid boundaries, which makes them a little bit skewed when viewed in a UTM projection. Because the base TIFF and JPG formats only support rectangular images, something must be used to fill in the areas around the quad such that the data fills a rectangle. This extra fill causes the border to appear.

One workaround for this problem is to reproject the images to Geographic before exporting them to a new file. This way the quads will be rectangular and you won't have the extra border around the data. You can change the projection for viewing and exporting the data by using the Projection tab on the Tools->Configuration dialog. See the earlier FAQ question for more details.

Another option is to use a format that supports transparency, like PNG or 24-bit RGB GeoTIFF, when doing your export, thus allowing Global Mapper to mark those border pixels as transparent on export. Note however that not all applications can handle image files with built-in transparency.

Question: How do I remove the collar from overlapping imagery files?


If the collar surrounding your imagery files is either black or white (or very close to one of those colors), you can use either the Darken or Lighten blend mode functionality in Global Mapper to remove the collars. To setup the blend modes, open the Control Center (found on the toolbar and under the Tools menu), highlight the imagery layers that you want to remove the collar from, and select the Options button.

If the color is black, select the Lighten blend mode from the Blend Mode drop-down list. If the collar color is white, select the Darken blend mode. Then press OK. Finally, you'll also need to set the background color of the Global Mapper view to be either black or white to match the collar color so that the non-overlapping regions aren't affected. You can change the background color under the View menu.

Question: How do I associate point features with files or web links?


You can treat any attribute/value pair associated with any vector feature (like point features) as either a link to a file on your local computer or a link to a web site. So to add a link, just create an attribute/value pair for the feature by first selecting the Feature Info tool, then clicking on the point feature, then pressing the Edit Feature button to bring up the edit dialog. On the edit dialog, add an attribute with a value that is either the filename or full URL to the web site, then press OK to return to the Feature Info dialog. Then, simply right click on the attribute/value pair in the Feature Info dialog and select the appropriate option from the popup menu to either open the value as a file or as a web link. If you already have the attributes assigned, there is of course no need to add them.

Question: How do I add text to the map without an accompanying symbol?


Select the New Point tool from the toolbar and click at the location of the map where you would like to place the text. In the resulting Modify Feature Info dialog box, type the text you would like to add in the Name field and choose Text from the Feature Type drop down list.

Question: How can I crop imagery to an irregular shape (i.e. an area) when exporting?


To crop imagery to an area feature or polygon on export either load the file containing the area feature or draw it using the Digitizer or Measure Tool. Then, select the area feature with the Digitizer Tool, and go to File->Export Raster and select the appropriate export format. The Export Bounds tab of the export options dialog that appears will have an option at the bottom to "Crop to Selected Area". Select this option and the export will be cropped to the selected area.

It is important to note that if you are exporting to an image format like JPG, GeoTIFF, or ECW, the resultant image will still be rectangular. The areas outside the selected crop area will be filled in with the currently selected background color. You can change the background color under the View menu.

Question: How do I copy the current cursor coordinates to the clipboard?


Use the Ctrl+L shortcut key to copy the current cursor coordinate string to the clipboard. Once in the clipboard, it can be pasted into any location that accepts text using the Paste command, usually associated with the Ctrl+V shortcut.

Question: How do I zoom or pan around when measuring something with the Measure Tool without canceling the measurement?


You will need to use the keyboard to zoom and pan around while using the Measure Tool. Switching tools will cause the measurement to be canceled. The arrow keys allow you to pan around and the Page Up/Page Down keys allow you to zoom in and out. You can also click and hold the middle mouse button to drag the map around.

Question: How do I import and project imagery (i.e. TIFF, JPG, etc.) files that have no projection or associated world files?


In Global Mapper you can rectify (georeference) any imagery, regardless of whether it has a world file. If you try to load imagery files with no positioning information, you will be prompted to rectify the image. You can also use the File->Rectify (Georeference) Imagery menu command to force the image to be rectified.

Question: How do I save map layers from an online data source for offline use?


After the required online data is displayed on in the map window, click the File menu and choose Export > Export Raster/Image Format. In the Export Options dialog box, make sure the Export Bounds settings match the geographic coverage requirements.

Leaving the default All Loaded Data may result in an extremely large file and significantly increase processing time. After the export process is complete, close the connection to the online data in the Overlay Control Center and import the previously exported file.

Question: How do I generate a list of elevations from a list of coordinates?


First load the elevation data that you wish to get the elevations from. Then use the File->Import Generic ASCII Text File(s) menu command to load a text file with a list of coordinates. Finally, use the File->Export Vector Data->Export Simple ASCII Text File menu command and make sure that the "Export Elevations for Each Vertex" option is checked.

This should generate a new file with the coordinates and the elevation for each point in your original coordinate list. You can also do this using the scripting language documented at

Question: How do I generate an elevation grid (i.e. DEM) from a file containing elevation contours or 3D points?


First, load the file(s) containing the contours and/or 3D points of interest into Global Mapper using either the File->Open Data File or File->Open Generic ASCII Text File menu command, depending on which is appropriate for the type of data that you are loading. Then, open the Overlay Control Center (under the Tools menu or press Alt+C) and select the layer(s) from which you want to generate the elevation grid. Finally, right click and select the Create Elevation Grid from 3D Vector Data option on the menu that pops up and away you go!

Question: How do I create a true-color image from imagery (i.e. Landsat) in which each color channel (red, green, and blue) is stored in separate files (i.e. TIFF files)?


You can do this using the blend mode functionality accessible from the Overlay Control Center. First, load the three TIFF files containing the separate color channels. Then, open the Overlay Control Center (under the Tools menu or press Alt+C) and select the layer containing the red colors. Press the Options button and on the Display tab change the Blend Mode selection to Keep Red, then press OK. Repeat this for the blue and green layers (selecting the Keep Blue and Keep Green blend modes respectively).

After doing that you should have a color image in the main view area, but it may still be hard to see. To improve that, select all three of the layers and press Options, then enable the Auto-Adjust Contrast setting and press OK. In many cases this will generate a very the 'true color' results can then be saved to a single full-color image using the GeoTIFF, BIL/BIP/BSQ or JPG raster export options.

Question: How to I recover a deleted feature?


Use the Ctrl+Shift+D keyboard shortcut to toggle the display of deleted features. Then, select the required feature with the Digitizer tool, right-click on the map, and choose 'Undelete' to restore the feature to its original state.

Follow us:    
Copyright © 2016 Blue Marble Geographics